你的位置:首页 > 现代教育 > 现代教育动态

信息技术在校园广播系统的应用略谈

作者:不详   来源:网络  已浏览【】次 文字:【】【】【

信息技术在校园广播系统的应用略谈

澳门威尼斯人赌城官网 肖敬友  电话:13438281239

关键字:广播系统  考试系统  易语言

  要:随着社会的发展,学校的考试越来越众多和复杂,尤其是中小学在一些平时考试中经常出现多个年级同时考试但时间又不一致;或有的年级在考试,有的年级在上课的情况等等,在种情况下,要保证学校教学次序的正常工作,就需要大量的人力来管理好考试的各项工作,尤其是广播信号的准确性,随着信息技术的发展,我作为一名信息技术的老师,我利用业余时间自学易语言,编写了一套完整的多场次多年级的语音考试系统,从而解决了澳门威尼斯人赌城官网的考试系统存在的一些问题。
  

一、目前中小学广播考试系统的现状及存在的问题。

现在,很多学校都配置了比较高档的校园广播系统,在一些大型考试中,会有相应的软件来完成比如:中考有中考指令,高考有高考指令。但是在平时的一些考试中,这两种指令就不太适合,比如周考、月考等等,因为时间和科目不同,所以不能解决考试播音问题。大部分学校都是人工播音,这样可能会出一些问题,比如:有的年级在考试,有的年级在上课,如果是上课时间或下课时间刚好是同一时间,播音员和铃声就重合,会造成老师和学生听不清楚,从而影响考试或上课;有些广播系统在打完上课铃声后会自动关闭系统,如果正好考试结束时,播音员播到一半声音就没了,也会影响整个考试的次序;有时,这个年级和上课年级之间是考试开始和结束时间一致,播音时就必须搞清楚,否则会出现很多问题。

二、信息技术对中小学广播考试系统的改进。

系统要求,本软件又易语言编写,可以在winxpwin7win8win10上运行,无需安装,软件小,一个主应用程序和语音包文件夹等优点。针对澳门威尼斯人赌城官网广播系统解决了如下一系列问题。

1、针对不同年级设置可以随教务处给的考试时间安排表设置。

比如:高一、高二、高三、初一、初二、初三六个年级同时考试,每个年级考试时间都可以精确到秒,因此,就解决了考试过程中出现并列声音现象,每个时间都会有独立的该年级的考试语音包,监考老师和学生就能清楚的知道是不是本年级考试是的语音,考试语音可以由语音生成软件合成,可以随时改变语音内容,从而方便临时语音调整。设置完毕后可以点一键设置按钮,完成每个年级的设置,不考试的年级可以不设置。如果设置错误的地方可以点取消一键设置,然后重新点一键盘设置来修改。操作界面非常友好,任何懂电脑的人都几分钟就学会了这个软件的设置。

2、解决了多次考试的设置,时间同步问题

由于不同年级考试的场次有很多次,如果每次都在原来的数据上进行修改很麻烦,因此,我设计了6场考试设置,因此,只需一次就可以把6场的考试设置好,这样可以节省考试操作员的时间,减少劳动强度。由于是电脑上运行的软件,有些电脑的时间可能会与北京时间有出入,我在本软件中加入了时间同步器,只要能上网的电脑,点击同步时间按钮就可以和北京时间同步,从而保证时间的同步性。

3、解决了考试和打铃两不误的问题。

如果有的年级在考试,有的又在上课。传统的必须在广播系统不断的切换,很麻烦,容易损坏广播系统。因此,我就在系统中加入了自动打铃系统,只需点击启动打铃,这样无需相互切换,就能自动完成相应打铃的功能;如果不需要打铃系统,只需点击关闭打铃,就可以保证考试过程中不出现铃声。

4、解决了误关和重复运行问题。

由于怕有人无意关掉本软件,因此设计时,在关闭程序时需要退出密码,必须密码正确才能关掉本程序,防止误关机;而且最小化后本程序会在任务栏最右下角显示图标。当已经运行了本程序,如果继续再点击运行本程序,系统会提示程序已经运行,从而避免多次多个程序出现。

本系统,在澳门威尼斯人赌城官网已经运行了几个月,基本能达到大型非高、中考的考试要求,为此我还在进一步完善本软件,以能适应很多学校的要求,希望能为更多的学校提供服务。由于篇幅有限我也把界面和部分源码公附在后面。

程序界面:


由于篇幅有限部分源代码:

.版本 2

.支持库 EThread

.支持库 spec

.程序集 窗口程序集1

.程序集变量 网络, 日期时间型

.程序集变量 本地网络差, 双精度小数型

.程序集变量 c1, 整数型, , , 第一场

.程序集变量 c1, 整数型

.程序集变量 c11, 整数型

.程序集变量 c11, 整数型

.程序集变量 c12, 整数型

.程序集变量 c12, 整数型

.程序集变量 c13, 整数型

.程序集变量 g35, 整数型

.程序集变量 g36, 整数型, , , 第一场完

.子程序 __启动窗口_创建完毕

' 不能重复运行本程序

.如果真 (打开事件同步对象 (2031619, , myappname) 0)  ' "myappname"可以是任何文本,但是最好要长一点以保证和系统中已有其他事件对象的名称不相冲突。

    信息框 (“不能重复运行本程序!, 0, )

    销毁 ()

    返回 ()

.如果真结束

创建事件同步对象 (0, , , myappname)

.子程序 __启动窗口_可否被关闭, 逻辑型

载入 (窗口2, , )

.子程序 __启动窗口_托盘事件

.参数 操作类型, 整数型

.如果真 (操作类型 1)

.如果真结束

_启动窗口.位置 1

_启动窗口.激活 ()

' _启动窗口.总在最前

_启动窗口.可视

置托盘图标 ({  }, )  ' 没段命令结束图标

' 结束 ()

.子程序 __启动窗口_位置被改变

.如果真 (_启动窗口.位置 2)  ' 最小化窗口 1 居中 2 最小化 3最大化)

    置托盘图标 (_启动窗口.图标, “我在这里”)  ' 必须图片

    _启动窗口.可视

.如果真结束

.子程序 _按钮39_被单击

信息框 (选择 (置现行时间 (增减时间 (取现行时间 (), 8, 本地网络差)), “同步时间成功,同步为: 到文本 (时间格式化 (增减时间 (取现行时间 (), 8, 本地网络差))), “同步时间失败”), 64, “提示”)

' c11

.子程序 _c1a1_被单击

c1 到整数 (c1001.内容)

c1 到整数 (c1002.内容)

c14 到整数 (zhc0113.内容)

时钟1.时钟周期 1000

' 标签18.标题 c11.内容

.子程序 _c1a2_被单击

c11 到整数 (c1003.内容)

c11 到整数 (c1004.内容)

c15 到整数 (zhc0112.内容)

时钟2.时钟周期 1000

' 标签18.标题 c11.内容

.子程序 _c1a3_被单击

c12 到整数 (c1005.内容)

c12 到整数 (c1006.内容)

c16 到整数 (zhc0111.内容)

时钟3.时钟周期 1000

' 标签18.标题 c11.内容

.子程序 _c1a4_被单击

c13 到整数 (c1007.内容)

c13 到整数 (c1008.内容)

c11 到整数 (c1009.内容)

时钟4.时钟周期 1000

' 标签18.标题 c11.内容

.子程序 _c1a5_被单击

c14 到整数 (c1010.内容)

c14 到整数 (c1011.内容)

c12 到整数 (c1012.内容)

时钟5.时钟周期 1000

.子程序 _c1a6_被单击

c15 到整数 (c1013.内容)

c15 到整数 (c1014.内容)

c13 到整数 (c1015.内容)

时钟6.时钟周期 1000

.子程序 _时钟1_周期事件

.如果真 (取小时 (取现行时间 ()) c1 取分钟 (取现行时间 ()) c1 取秒 (取现行时间 ()) c14)

    播放音乐 (wav/领试卷c1.wav , )

    时钟1.时钟周期 0

    ' 信息框 (“时间到1, 0, )

.如果真结束

.子程序 _时钟2_周期事件

.如果真 (取小时 (取现行时间 ()) c11 取分钟 (取现行时间 ()) c11 取秒 (取现行时间 ()) c15)

    播放音乐 (wav/分发答题卡c1.wav , )

    时钟2.时钟周期 0

    ' 信息框 (“时间到1, 0, )

.如果真结束

.子程序 _时钟3_周期事件

.如果真 (取小时 (取现行时间 ()) c12 取分钟 (取现行时间 ()) c12 取秒 (取现行时间 ()) c16)

    播放音乐 (wav/分发试卷c1.wav, )

    时钟3.时钟周期 0

    ' 信息框 (“时间到1, 0, )

.如果真结束

.子程序 _时钟4_周期事件

.如果真 (取小时 (取现行时间 ()) c13 取分钟 (取现行时间 ()) c13 取秒 (取现行时间 ()) c11)

    播放音乐 (wav/开始考试c1.wav , )

    时钟4.时钟周期 0

    ' 信息框 (“时间到1, 0, )

.如果真结束

.子程序 _时钟5_周期事件

.如果真 (取小时 (取现行时间 ()) c14 取分钟 (取现行时间 ()) c14 取秒 (取现行时间 ()) c12)

    播放音乐 (wav/还有15分钟c1.wav , )

    时钟5.时钟周期 0

    ' 信息框 (“时间到3, 0, )

.如果真结束

.子程序 _时钟6_周期事件

.如果真 (取小时 (取现行时间 ()) c15 取分钟 (取现行时间 ()) c15 取秒 (取现行时间 ()) c13)

    播放音乐 (wav/考试结束c1.wav , )

    时钟6.时钟周期 0

    ' 信息框 (“时间到3, 0, )

.如果真结束

参考:易语言设计实例

附图:

下一篇: 上一篇:信息技术辅助地理教学

  Copyright©2017 澳门威尼斯人赌城官网校 All Rights Reserved
澳门威尼斯人赌城官网现代教育办公室技术部 信息技术管理中心

全国党政机关事业单位 川公安备ICP备案编号:澳门威尼斯人赌城官网-1